• Stop being a LURKER - join our dealer community and get involved. Sign up and start a conversation.

What in the Heck is Going On With my Dealer.com sites in Google SRP's?????

Alexander Lau

Sr. Refresher
Feb 11, 2015
2,189
606
113
First Name
Alex
Hi guys, I'm at nada and I can't go into full detail about this now but, I can tell you the problem isn't fixed. Submitting the site in GWT helped some. There's still pages that show across each of our sites with the wrong info when using a search operator. I can tell you this though, I'm in the right spot to research other providers and it is at the top of my list while here at NADA. Sorry, that came out a little wrong! I've sent my trusted sidekick "Abe Froman" to research site providers.
It doesn't look like it's fixed and it seems systemic to Dealer.com sites. They're the ones serving the incorrect data.
 

Bob George

Noob
Aug 1, 2012
3
9
3
First Name
Bob
Examples?
Progress has been made, but there is more work to be done. Here are the things implemented in Feb:

  • Set "noindex, follow" on the following pages:
    • /blog/video/*
    • /video-gallery/*
    • /blog/tag/*
    • /blog/authors/*
    • /blog/categories/*
    • /legal.htm
    • /privacy.htm
    • /carfinder/index.htm
  • Set “noindex, nofollow” on the following pages:
    • /mycars/*
    • /inventory-details/print.htm
  • Add/Update the following pages to the robots.txt file:
    • /inventory-details/print.htm
    • /specials/trims.htm
    • /reserve-it-now/form.htm
    • Update /*fragment.htm$ to /*fragment.htm (eg remove the “$”)
  • Add self-pointing canonical tags to all pages that didn’t have them already
  • Old Showroom Page Redirects - When data is no longer present, set the page to 301 redirect to showroom index

We're continuing to chase this, I'll keep this group updated.
 

craigh

Super Moderator
May 19, 2011
1,666
1,080
114
First Name
Craig
I can see some of these tactics helping, but some of the examples I saw were straight up service pages.
Can't no follow those, don't really want to mess with the rank too much.

I assume the proper fix is to make each service page unique (Day 1 SEO ;) ) and then re-submit and wait.
However, this appears to be past that point for some pages/sites.
 

ChrisR

Refresher
Oct 12, 2015
138
117
43
First Name
Christian
I would have to say this is still broken. I was just informed by DDC that the Composer > Blog system is being deprecated, and I should have been using Social > SmartBlog to upload our blog posts. Also, having been informed that I will have to copy my posts to the newer system, I began doing that. The blog tags section decided to randomly update itself to some Eugene, Oregon Dodge tags on some posts, others with a list of SUV and crossover models. None of these tags are anywhere CLOSE to being related to the post itself.

DDC's initial response was that it must have been how I cut and pasted the post content over. I was told this will be looked into. I am curious what the outcome will be.
 
Reactions: craigh

craigh

Super Moderator
May 19, 2011
1,666
1,080
114
First Name
Craig
Wait a second. Are you suggesting that the tags showed up in the composer? Or on the actual page? That is a much bigger problem than Google inappropriately indexing content that was never on the page.
 

ChrisR

Refresher
Oct 12, 2015
138
117
43
First Name
Christian
Wait a second. Are you suggesting that the tags showed up in the composer? Or on the actual page? That is a much bigger problem than Google inappropriately indexing content that was never on the page.
I have attached what I just saw in the SmartBlog composer.

As you can guess by the blog title, it would give me ZERO benefit to promote Eugene, OR, Dodge Techs, etc
 

Attachments

craigh

Super Moderator
May 19, 2011
1,666
1,080
114
First Name
Craig
What the Fuuuuuuuu..
This changes everything.